Bug 108597 - [CI][SHARDS] igt@kms_content_protection@(legacy|atomic) - fail - Content Protection not enabled
Summary: [CI][SHARDS] igt@kms_content_protection@(legacy|atomic) - fail - Content Prot...
Status: RESOLVED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high major
Assignee: Ramalingam C
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-30 09:23 UTC by Martin Peres
Modified: 2019-04-04 12:58 UTC (History)
1 user (show)

See Also:
i915 platform: BXT, ICL, KBL
i915 features: display/HDCP


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2018-10-30 09:23:22 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5046/shard-apl6/igt@kms_content_protection@atomic.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5046/shard-apl6/igt@kms_content_protection@legacy.html

Starting subtest: atomic
(kms_content_protection:5599) CRITICAL: Test assertion failure function test_cp_enable_disable, file ../tests/kms_content_protection.c:181:
(kms_content_protection:5599) CRITICAL: Failed assertion: ret
(kms_content_protection:5599) CRITICAL: Last errno: 25, Inappropriate ioctl for device
(kms_content_protection:5599) CRITICAL: Content Protection not enabled
Subtest atomic failed.
Comment 1 Ramalingam C 2018-10-30 15:46:02 UTC
Seeing this on APL particularly on LSPCon as an HDCP repeater. HDCP failed at repeater authentication due to timeout.

Need debugging.
Comment 2 Ramalingam C 2018-11-02 17:02:09 UTC
As on kbl with MCA lspcon HDCP1.4 is passing with Power_well fix posted at https://patchwork.freedesktop.org/patch/260059/

Need to check whether this is particular lspcon vendor's bug. Added a debugging patch to a series at https://patchwork.freedesktop.org/series/51968/.

The trybot result will shed some light on the issues.
Comment 3 Ramalingam C 2018-11-03 05:07:28 UTC
On shard_kbl1, when kms_content_protection executed alone, authentication was passing but at https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_3178/shard-kbl6/igt@kms_content_protection@atomic.html kms_content_protection is timedout at waiting for ksv_list.

Wondering whether sequence of the tests plays a role here? debug WIP.
Comment 4 Martin Peres 2018-11-03 10:45:36 UTC
(In reply to Ramalingam C from comment #3)
> On shard_kbl1, when kms_content_protection executed alone, authentication
> was passing but at
> https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_3178/shard-kbl6/
> igt@kms_content_protection@atomic.html kms_content_protection is timedout at
> waiting for ksv_list.
> 
> Wondering whether sequence of the tests plays a role here? debug WIP.

This would not be the first time... Good luck!
Comment 5 Martin Peres 2018-11-05 15:13:35 UTC
Also seen on KBL: https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4708/shard-kbl7/igt@kms_content_protection@atomic.html

Starting subtest: atomic
(kms_content_protection:1058) CRITICAL: Test assertion failure function test_cp_enable_disable, file ../tests/kms_content_protection.c:181:
(kms_content_protection:1058) CRITICAL: Failed assertion: ret
(kms_content_protection:1058) CRITICAL: Last errno: 25, Inappropriate ioctl for device
(kms_content_protection:1058) CRITICAL: Content Protection not enabled
Subtest atomic failed.
Comment 6 Martin Peres 2018-11-15 13:20:53 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_142/fi-skl-gvtdvm/igt@kms_content_protection@legacy.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_142/fi-skl-6770hq/igt@kms_content_protection@legacy.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_142/fi-skl-6770hq/igt@kms_content_protection@atomic.html

Starting subtest: atomic
(kms_content_protection:1508) CRITICAL: Test assertion failure function test_cp_enable_disable, file ../tests/kms_content_protection.c:181:
(kms_content_protection:1508) CRITICAL: Failed assertion: ret
(kms_content_protection:1508) CRITICAL: Last errno: 25, Inappropriate ioctl for device
(kms_content_protection:1508) CRITICAL: Content Protection not enabled
Subtest atomic failed.
Comment 8 Ramalingam C 2019-03-15 12:43:26 UTC
Martin,

We need to file different bugs for the content protection failures based on the cause for it. 
This is needed because few failures are due to the HDCP sink, which can't be fixed.

The cause has to be picked from the kernel demsg debug logs as given below. 

1. [drm:intel_hdcp_read_valid_bksv.isra.0 [i915]] Bksv is invalid
      Ex: https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_3967/fi-icl-u3/igt@kms_content_protection@legacy.html

2. [drm:intel_hdcp_auth [i915]] KSV list failed to become ready (-110)
      Ex: https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5750/shard-kbl5/igt@kms_content_protection@atomic.html


Could you please help with this? This bug can be used for one of the above bugs.
Comment 9 Martin Peres 2019-04-04 12:57:51 UTC
I finally took the time to split this bug! Sorry for the delay...

(In reply to Ramalingam C from comment #8)
> Martin,
> 
> We need to file different bugs for the content protection failures based on
> the cause for it. 
> This is needed because few failures are due to the HDCP sink, which can't be
> fixed.
> 
> The cause has to be picked from the kernel demsg debug logs as given below. 
> 
> 1. [drm:intel_hdcp_read_valid_bksv.isra.0 [i915]] Bksv is invalid
>       Ex:
> https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_3967/fi-icl-u3/
> igt@kms_content_protection@legacy.html

https://bugs.freedesktop.org/show_bug.cgi?id=110322

> 
> 2. [drm:intel_hdcp_auth [i915]] KSV list failed to become ready (-110)
>       Ex:
> https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5750/shard-kbl5/
> igt@kms_content_protection@atomic.html

https://bugs.freedesktop.org/show_bug.cgi?id=110321


3. Timed out waiting for Ri prime match

https://bugs.freedesktop.org/show_bug.cgi?id=110325


> 
> 
> Could you please help with this? This bug can be used for one of the above
> bugs.

Done! And closing this one now, since it did not catch anything else but the above issues since drmtip_212 and the reproduction rate of the issue was every single drmtip run since 198.
Comment 10 CI Bug Log 2019-04-04 12:58:02 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.