Bug 30359 - Dispatch GenericEvents sent through xGESendEventReq
Summary: Dispatch GenericEvents sent through xGESendEventReq
Status: RESOLVED DUPLICATE of bug 30357
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-24 04:34 UTC by Carlos Garnacho Parro
Modified: 2011-10-06 11:39 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
patch (6.85 KB, patch)
2010-09-24 04:34 UTC, Carlos Garnacho Parro
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garnacho Parro 2010-09-24 04:34:55 UTC
Created attachment 38931 [details] [review]
patch

Hi!,

I'm attaching a patch to use the xGESendEventReq added in bug #30357, so sent GenericEvents are dispatched in the same way than core events sent through xSendEventReq. 

One pending question here would be how to handle with a version increase in the Xge protocol headers, would the server just depend on a higher xextproto package version? or some ifdefs should be in place?
Comment 2 Jeremy Huddleston Sequoia 2011-10-06 11:39:27 UTC

*** This bug has been marked as a duplicate of bug 30357 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.