Bug 30361 - Add handler to convert XI2 events to the wire protocol
Summary: Add handler to convert XI2 events to the wire protocol
Status: RESOLVED DUPLICATE of bug 30357
Alias: None
Product: xorg
Classification: Unclassified
Component: Lib/Xi (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2010-09-24 04:45 UTC by Carlos Garnacho Parro
Modified: 2011-10-06 11:40 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
patch (3.86 KB, patch)
2010-09-24 04:45 UTC, Carlos Garnacho Parro
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garnacho Parro 2010-09-24 04:45:50 UTC
Created attachment 38933 [details] [review]
patch

Hi!,

I'm adding a patch to have a handler in libXi to convert XI2 events to the core protocol, it relies on the patch from bug #30358 to register such handler.

This patch is part of a bug series to make XSendEvent() work with GenericEvents (and specifically XI2):
https://bugs.freedesktop.org/show_bug.cgi?id=30357
https://bugs.freedesktop.org/show_bug.cgi?id=30358
https://bugs.freedesktop.org/show_bug.cgi?id=30359
https://bugs.freedesktop.org/show_bug.cgi?id=30360

At the moment only key press/release events are translated, which is enough for a XI2-aware version of the XEmbed protocol to work, I'll keep working on making the other event types to work as well.
Comment 1 Jeremy Huddleston Sequoia 2011-10-06 11:40:00 UTC

*** This bug has been marked as a duplicate of bug 30357 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.