Bug 94287 - Verifying "XQuartz.pkg" hangs
Summary: Verifying "XQuartz.pkg" hangs
Status: RESOLVED NOTOURBUG
Alias: None
Product: XQuartz
Classification: Unclassified
Component: Installer (show other bugs)
Version: development (betas, rcs, git)
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium critical
Assignee: Jeremy Huddleston Sequoia
QA Contact: Jeremy Huddleston Sequoia
URL:
Whiteboard:
Keywords:
: 94674 96454 97842 97966 98843 101437 101808 104396 107387 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-02-25 06:00 UTC by Ian Boardman
Modified: 2018-07-27 22:20 UTC (History)
9 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Description Ian Boardman 2016-02-25 06:00:21 UTC
2.7.9 RC2 won't install on Mac OS X 10.11.3. Opening the package, dialog Verifying "Quartz.pkg" hangs, no progress, no error message.
Comment 1 Ian Boardman 2016-02-25 06:16:07 UTC
Embarrassing. I logged out and back in again. Package opened just fine. My apologies.
Comment 2 Michael Gross 2016-06-14 17:10:24 UTC
I'm having this same issue. The Verifying dialog opens but the progress bar never gets started. Also tried v2.7.8 with the same result so this likely has something to do with my environment:

  - OS X 10.11.5
  - Mac mini (Late 2012)
  - 2.5 GHz Intel Core i5
  - 10 GB
  - Boot from external USB 3.0

Or perhaps some part of the validation mechanism is broken.

Also, there is a previous installation of XQuartz on the system and Apple's X11 is throwing errors since the upgrade to El Capitan.
Comment 3 Michael Gross 2016-06-14 17:25:13 UTC
Didn't see the previous comments until after my post that reopened this bug. Logged out and back in and the installer works.
Comment 4 Jeremy Huddleston Sequoia 2016-06-14 19:54:20 UTC
If someone experiences this issue, please run 'sudo sysdiagnose' and file a radar at http://bugreport.apple.com with the resulting tarball, so it can be investigate.
Comment 5 Jeremy Huddleston Sequoia 2016-06-14 20:02:22 UTC
*** Bug 96454 has been marked as a duplicate of this bug. ***
Comment 6 gontzol 2016-06-15 03:31:39 UTC
I had the exact same problem as well, with v2.7.9. Here is my environment:

- OS X 10.11.5
- MacBook Pro (13-inch, Early 2015)
- 3.1 GHz Intel Core i7
- 16 GB RAM
- Boot from built-in SSD drive

This is a new machine for me, and I had just recently used Migration Assistant to copy my system configuration and applications etc. from my Time Machine backup of another MBP running 10.10 (Yosemite) that already had XQuartz installed. I had just uninstalled XQuartz to test something, using instructions from http://xquartz.macosforge.org/trac/wiki/X11-UsersFAQ#UninstallSnowLeopardorLater. I had to log out and back in in order for the installer to work.
Comment 7 Jeremy Huddleston Sequoia 2016-06-15 04:18:41 UTC
Did you happen to take a sysdiagnose and file a radar at http://bugreport.apple.com as mentioned in comments above?  If so, can you please point me to it, so I can take a look at it and get it assigned to the appropriate team?
Comment 8 Sanchi Vaishnavi 2016-06-18 09:46:36 UTC
I have had the exact issue with both the versions, 2.7.8 and 2.7.9 on my Mac. I have run sudo sysdiagnose, this is the problem id: 26876973. I couldn't find a URL to it, my apologies. 

On a side note, upon trying to search the tarball on my drive, I noticed that the folder 'tmp' is hidden as well as its parent folders, var and private. I even tried the option, 'reveal in folder' but to no avail. Thus I had to copy it to another visible directory and then upload it. 
My point is, that this might hinder the people who are less comfortable with tech to upload the sydiagnose results.
Comment 9 Jeremy Huddleston Sequoia 2016-06-18 17:05:29 UTC
After completion of the sysdiagnose, a Finder window should open with it automatically.  Thanks for the radar.  Investigating it.  If anyone else hits this, please do the same.
Comment 10 juiceguava 2016-06-30 15:10:17 UTC
I have the same problem with installing 2.7.9. it stuck at Verifying with no error.

osx 10.11.5
Mac Air (Mid 2013)
1.3 GHz Intel Core i5
8 GB
Comment 11 Jeremy Huddleston Sequoia 2016-06-30 20:32:59 UTC
@juiceguava (and everyone else), there's nothing I can do for you unless you take a sysdiagnose and file a radar.
Comment 12 Richard Xia 2016-07-03 11:22:55 UTC
I've also run into this bug. I ran sysdiagnose and created a bug report with id 27151340. Similar to the others, I'm running OS X 10.11.4, on a 2015 Macbook Pro.

> On a side note, upon trying to search the tarball on my drive, I noticed that the folder 'tmp' is hidden as well as its parent folders, var and private. I even tried the option, 'reveal in folder' but to no avail. Thus I had to copy it to another visible directory and then upload it. 

I also ran into this problem and learned that when the file dialog box is open, you can press ~ to open up another window where you can type in the absolute file path of a directory you want to jump to.
Comment 13 Jeremy Huddleston Sequoia 2016-07-28 09:20:09 UTC
FWIW, this issue was fixed in Sierra.
Comment 14 Jeremy Huddleston Sequoia 2016-09-18 10:06:39 UTC
*** Bug 97842 has been marked as a duplicate of this bug. ***
Comment 15 Jeremy Huddleston Sequoia 2016-09-18 10:07:19 UTC
*** Bug 94674 has been marked as a duplicate of this bug. ***
Comment 16 Eric Vantillard 2016-09-21 08:07:33 UTC
Same here on mac book pro.

As a workaround, see this URL for running the installer manually:

http://osxdaily.com/2016/07/26/fix-stuck-pkg-verifying-installer-mac-os-x/

I can fill a bug report using sysdiagnose if it's still useful.
Comment 17 Eric Vantillard 2016-09-21 08:38:37 UTC
my bug report id is 28402781
Comment 18 Jeremy Huddleston Sequoia 2016-09-22 16:16:37 UTC
Eric, as mentioned above, the issue is fixed in Sierra.  There is no need for new reports.
Comment 19 Britni Cox 2016-09-22 16:24:03 UTC
Thank you, Eric; that link was incredibly helpful to figure out how to get it to work once Sierra was downloaded. It still wasn't verifying until I followed the instructions in that article, and it's working now.
Comment 20 Jeremy Huddleston Sequoia 2016-09-22 17:17:51 UTC
Britni, are you saying that you're seeing this hang in Sierra?  That should not be the case.  Please confirm.
Comment 21 Britni Cox 2016-09-22 17:26:07 UTC
Yes, it does not start verifying just from downloading Sierra. I even deleted the original XQuartz and re-downloaded it to make sure it was fresh, and it did not verify. I had to do so manually.
Comment 22 Jeremy Huddleston Sequoia 2016-09-23 03:34:59 UTC
Did you take a sysdiagnose in the stuck state and file a radar when you encountered this on Sierra?

What do you mean by "had to do so manually"?
Comment 23 Jeremy Huddleston Sequoia 2016-09-29 07:29:04 UTC
*** Bug 97966 has been marked as a duplicate of this bug. ***
Comment 24 Leon Miller-Out 2016-11-02 17:39:46 UTC
The workaround (from the OSXDaily.com URL) is:
1. Open /System/Library/CoreServices/Installer.app. The easiest way to do this is to run `open -a Installer` in a terminal.
2. Open the XQuartz .pkg file from within Installer.

It installed fine for me when I did this.

According to the OSXDaily article, this is a problem with other apps as well, so it may not be XQuartz's problem to fix. I agree with the NOTOURBUG status.
Comment 25 Vincent Mader 2017-01-25 15:24:36 UTC
I don't know if this helps, but for me it worked when I copied the XQuartz.pkg to my Desktop, while I couldn't install from the .dmg volume. You might try it out
Comment 26 Jeremy Huddleston Sequoia 2017-12-31 07:17:00 UTC
*** Bug 98843 has been marked as a duplicate of this bug. ***
Comment 27 Jeremy Huddleston Sequoia 2017-12-31 07:17:11 UTC
*** Bug 101437 has been marked as a duplicate of this bug. ***
Comment 28 Jeremy Huddleston Sequoia 2017-12-31 07:17:20 UTC
*** Bug 101808 has been marked as a duplicate of this bug. ***
Comment 29 Jeremy Huddleston Sequoia 2017-12-31 07:17:32 UTC
*** Bug 104396 has been marked as a duplicate of this bug. ***
Comment 30 Jeremy Huddleston Sequoia 2018-07-27 22:20:04 UTC
*** Bug 107387 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.